MantisBT - Doomseeker
View Issue Details
0003670Doomseeker[All Projects] Suggestionpublic2019-06-25 14:152019-07-30 10:13
Pol M 
Zalewa 
lowminoralways
closedfixed 
LinuxArchx86-64
1.2 
1.31.3 
0003670: Ubuntu 14.04 no longer supported, update docker image.
As commented in 0003514, Ubuntu 14.04 is not supported, and we need to move to 16.04. This update should include dropping qt4.
No tags attached.
Issue History
2019-06-25 14:15Pol MNew Issue
2019-06-25 15:18WubTheCaptainStatusnew => acknowledged
2019-06-25 16:06Pol MAssigned To => Zalewa
2019-06-25 16:06Pol MStatusacknowledged => assigned
2019-06-26 02:53WubTheCaptainTarget Version => 1.3
2019-06-30 06:17ZalewaNote Added: 0020846
2019-06-30 06:17ZalewaStatusassigned => needs review
2019-06-30 06:20ZalewaNote Edited: 0020846bug_revision_view_page.php?bugnote_id=20846#r12703
2019-06-30 06:24ZalewaNote Edited: 0020846bug_revision_view_page.php?bugnote_id=20846#r12704
2019-06-30 11:46WubTheCaptainStatusneeds review => needs testing
2019-07-10 05:54ZalewaNote Added: 0020868
2019-07-10 05:54ZalewaStatusneeds testing => resolved
2019-07-10 05:54ZalewaFixed in Version => 1.3
2019-07-10 05:54ZalewaResolutionopen => fixed
2019-07-30 10:13WubTheCaptainStatusresolved => closed

Notes
(0020846)
Zalewa   
2019-06-30 06:17   
(edited on: 2019-06-30 06:24)
Commit:https://bitbucket.org/Doomseeker/doomseeker/commits/1d6c92655e36304d0874dfb15ed14ee783eebfc6 [^]
Verified:https://bitbucket.org/Doomseeker/doomseeker/addon/pipelines/home#!/results/102 [^]

As far as the Docker images go, I have retagged the old "latest" as "ubuntu-14.04", then built a new Docker image off the Dockerfile with the "COPY" and "WORKDIR" statements commented out and then tagged this new image as the new "latest" and also as "ubuntu-16.04".

(0020868)
Zalewa   
2019-07-10 05:54   
I suppose the autobuilds still working are a sufficient proof that this was done correctly.