MantisBT - Zandronum
View Issue Details
0003190Zandronum[All Projects] Bugpublic2017-07-17 14:282020-04-11 00:45
Frits 
Torr Samaho 
normalminorsometimes
resolvedfixed 
MicrosoftWindowsXP/Vista/7
3.0-beta 
3.0 
0003190: Coopspy weapon desync when autoswitch on pick-up is disabled
I Noticed in LCA and Complex (not tested in vanilla yet) that when you are coopspying someone weapon desyncs happen if that person picks up a gun and has automatic weapon switch disabled. The spy thinks that the switch has happened and will sees BFG balls out of a chaingun for example. When the player manually switches guns the behavior get's corrected.


Addendum: I've also seen an armor desync and someone else reported clientside ammo desyncs in LCA, but I do not know the specifics of these ones yet.
1)Spy someone with automatic weapon switch disabled and have him pick up a new gun.
2) Player fires and spy notices the desync
No tags attached.
Issue History
2017-07-17 14:28FritsNew Issue
2017-07-17 18:51Edward-sanNote Added: 0018056
2017-07-17 18:51Edward-sanStatusnew => feedback
2017-07-18 07:25FritsNote Added: 0018062
2017-07-18 07:25FritsStatusfeedback => new
2017-07-22 17:28Ru5tK1ngNote Added: 0018077
2017-07-23 19:42Torr SamahoNote Added: 0018090
2017-07-23 19:43Torr SamahoAssigned To => Torr Samaho
2017-07-23 19:43Torr SamahoStatusnew => needs testing
2017-07-30 08:01FritsNote Added: 0018118
2017-08-01 18:10Torr SamahoNote Added: 0018130
2020-04-11 00:45Ru5tK1ngNote Added: 0021260
2020-04-11 00:45Ru5tK1ngStatusneeds testing => resolved
2020-04-11 00:45Ru5tK1ngResolutionopen => fixed
2020-04-11 00:45Ru5tK1ngFixed in Version => 3.0

Notes
(0018056)
Edward-san   
2017-07-17 18:51   
Does it happen in 2.1?
(0018062)
Frits   
2017-07-18 07:25   
I have never experienced it with 2.1. and it's glaringly obvious in 3.0. I will test it to be completely sure when I have some time.
(0018077)
Ru5tK1ng   
2017-07-22 17:28   
I had someone tell me they witnessed someone who has autoswitch enabled still desync to those who are coopspying.
(0018090)
Torr Samaho   
2017-07-23 19:42   
https://bitbucket.org/zandronum/zandronum-sandbox/commits/487b39baa95d48137a1d8d5743241272ee016e3c [^] may fix the issue. Can somebody test this? I can supply a build if necessary.
(0018118)
Frits   
2017-07-30 08:01   
I will test this for you if you can supply a build. I am a computer illiterate after all.
(0018130)
Torr Samaho   
2017-08-01 18:10   
No problem. Here is a binary that contains the fix.
(0021260)
Ru5tK1ng   
2020-04-11 00:45   
Couldn't reproduce in 3.1beta. Assuming it was fixed long ago since no one reported any issue. Reopen if necessary.