Page 1 of 1

Doomseeker 1.1

Posted: Tue Jun 13, 2017 1:49 am
by Blzut3
I'm sure some of you have already noticed auto updates going out the past few days, so about time for the announcement. Doomseeker 1.1 has been released!

The changelog is pretty sizeable as one might expect from 2 years. A few cherry picked highlights:
  • Migrated from Qt4 to Qt5.
  • GeoLite IP2C.
  • New SRB2 plugin. Vavoom plugin removed.
  • Option to install Freedoom in the menu.
  • Proper support for Chocolate Doom's multiple game binaries.
  • Support for alternate binaries (including testing binaries) in the server creation dialog.
  • Support for Zandronum 3 DMFlags.
Although we've migrated to Qt5, it remains possible to build Doomseeker against Qt4 and this is used to build the Mac binaries for PowerPC and old versions of OS X. Between the lack of proper modern C++ integration and naturally the continued divergence in API between Qt4 and Qt5, it is likely that this will be the last version to build against Qt4 and thus support those platforms. For Intel Macs it might be possible to continue to support 10.6 with a hybrid of an older version of Qt5, but it's likely that OS X 10.9 will be the minimum.

Download

Re: Doomseeker 1.1

Posted: Tue Jun 13, 2017 3:10 pm
by Zalewa
Released on my birthday. Thumbs up!

Re: Doomseeker 1.1

Posted: Wed Jun 14, 2017 12:07 am
by HeX9109
Congrats on the release guys!

Re: Doomseeker 1.1

Posted: Thu Jun 22, 2017 7:59 am
by Polygon
Great work :D!

Re: Doomseeker 1.1

Posted: Sun Jun 25, 2017 4:02 pm
by Monsterovich
"Well done."
[spoiler]Image[/spoiler]

Re: Doomseeker 1.1

Posted: Sun Jun 25, 2017 5:40 pm
by Zalewa
Can you reproduce this?

Re: Doomseeker 1.1

Posted: Wed Jul 12, 2017 11:54 pm
by mistamontiel
The previous one didn't update properly , two error boxes would popup then Doomseeker would launch

DL'd v1.1 and perfect ! And surfing for SRB2 is MUCH easier now ! Cheers much !!!