Zandronum 1.3

News and events are posted here. Threads also show up in the Latest News section.
User avatar
Torr Samaho
Topic author
Lead Developer
Offline
Posts: 1428
Joined: Fri May 25, 2012 6:03 pm

RE: Zandronum 1.3

Post#61 by Torr Samaho » Sat Jan 10, 2015 10:33 am

Inkubus wrote:So can this new database thing be used to save online games?

Mods can use the database to persistently save data, but mods don't have access the whole game state in such a way that they could save and restore it. You should be able to make a mod though that saves and restores a player's inventory for instance.

User avatar
Fincer
New User
Offline
Posts: 6
Joined: Tue Feb 24, 2015 5:47 pm

RE: Zandronum 1.3

Post#62 by Fincer » Wed Mar 11, 2015 11:44 pm

Zandronum on Arch Linux has serious troubles which are *somehow* related to the tar.bz2 packages you provide on zandronum download page:

http://zandronum.com/downloads/zandronu ... 64.tar.bz2 (64-bit)
http://zandronum.com/downloads/zandronu ... 86.tar.bz2 (32-bit)

The original symlinks used by zandronum AUR package are actually linked to system wide OpenSSL 1.0.0 libraries. If I use these symlinks, I get an error message: "no version information available".

I also tried another approach and installed openssl098 from AUR. I fixed zandronum AUR PKGBUILD script so that libcrypto and libssl symlinks refer correctly to system wide 0.9.8 version of OpenSSL library. However, zandronum server still complains about "no version information available" for libcrypto and refuses to launch. I have double checked the symlinks, and they have been correctly set up.

So, both 0.9.8 and 1.0.0 library versions tried out. The result: I can't launch zandronum server session, regardless what I do.

Any help is really, really appreciated.

User avatar
skyrimguy
 
Offline
Posts: 81
Joined: Sun Jul 29, 2012 8:35 am

RE: Zandronum 1.3

Post#63 by skyrimguy » Thu Mar 12, 2015 5:58 am

^There's another approach; compile it from source.

User avatar
Fincer
New User
Offline
Posts: 6
Joined: Tue Feb 24, 2015 5:47 pm

RE: Zandronum 1.3

Post#64 by Fincer » Thu Mar 12, 2015 7:44 am

Yup, no probs. with that.

Anyway. Zandronum versions 1.3 and 2.0 are compatible with each other in a multiplayer game, aren't them? My friend is using version 1.3 and I would still like to be able to play with him online.
Last edited by Fincer on Thu Mar 12, 2015 7:45 am, edited 1 time in total.

User avatar
Sean
Zandronum Tester
Offline
Posts: 660
Joined: Thu Jan 16, 2014 9:09 pm
Contact:

RE: Zandronum 1.3

Post#65 by Sean » Thu Mar 12, 2015 8:13 am

Fincer wrote:Anyway. Zandronum versions 1.3 and 2.0 are compatible with each other in a multiplayer game, aren't them? My friend is using version 1.3 and I would still like to be able to play with him online.


I was going to be sarcastic, but I'm feeling nice today.

So, no, they are not compatible. 2.0 is a major upgrade over 1.3. Your friend will need to update to 2.0.

Code: Select all

<Decay> csnxs try being less bitter and actually helpful to the community, thanks

User avatar
Dark-Assassin
Maintenence Crew
Offline
Posts: 913
Joined: Fri May 25, 2012 4:25 am

RE: Zandronum 1.3

Post#66 by Dark-Assassin » Thu Mar 12, 2015 9:20 am

No Major or Minor revisions are compatible with each other. Only the Sub-Minor (Bugfix) revisions may have a possibility of being backwards (or possibly forwards) compatible with the Dedicated Server. But IDK if that's the case, they could be all incompatible with any other version.


Return to “News & Announcements”



Who is online

Users browsing this forum: No registered users and 1 guest