Zandronum 2.0 Testing: Sundays 12 noon EST

Public forum for Zandronum's testers.

Moderator: Developers

one_Two
Addicted to Zandronum
Posts: 1753
Joined: Thu Jun 07, 2012 4:47 pm

RE: Zandronum 2.0 Testing; let's do this!

#21

Post by one_Two » Mon Dec 30, 2013 4:57 pm

I experienced some problems alt-tabbing out in windows, seemed to freeze up my system which previous zan version didn't do.

User avatar
Guardsoul
Forum Regular
Posts: 495
Joined: Wed Jun 06, 2012 6:09 pm
Location: Creating the world

RE: Zandronum 2.0 Testing; let's do this!

#22

Post by Guardsoul » Mon Dec 30, 2013 5:00 pm

Hypnotoad, you forgot to mention the portal issue.

[spoiler="Screenshots]
This is how it looked in Zandronum 1.2
Image

How it looks now
Image

From the lower zone (MASSIVE HOM!)
Image
[/spoiler]
I dont care about how bad your maps are. Everything can be improved.
Banned for cheating at DoomBuilder.

User avatar
Dusk
Developer
Posts: 581
Joined: Thu May 24, 2012 9:59 pm
Location: Turku

RE: Zandronum 2.0 Testing; let's do this!

#23

Post by Dusk » Mon Dec 30, 2013 6:26 pm

Hypnotoad wrote: Linux users seem to report movement jitter/lag issues that make the game unplayable. Edward-san and Positron who are both linux users had this problem, when Edward tested on an equivalent server for 1.2 the issue was not present for him.
Using a clean INI fixed this for me.

Edward-san
Developer
Posts: 382
Joined: Fri May 25, 2012 8:14 pm

RE: Zandronum 2.0 Testing; let's do this!

#24

Post by Edward-san » Mon Dec 30, 2013 6:58 pm

if you change cl_capfps to true with clean ini , it is screwed up again ...

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing; let's do this!

#25

Post by Torr Samaho » Mon Dec 30, 2013 7:23 pm

Please open tickets for all issues found. Some of the issues mentioned in this thread already have tickets, some don't. Without individual tickets we'll quickly lose track.

User avatar
ibm5155
Addicted to Zandronum
Posts: 1640
Joined: Tue Jun 05, 2012 9:32 pm
Location: Somewhere, over the rainbow

RE: Zandronum 2.0 Testing; let's do this!

#26

Post by ibm5155 » Mon Dec 30, 2013 7:35 pm

Hey, does someone have some iuse with recorded demos? I tried one that I did to check the lag on jump maze testing, but, the first time I got a fatal error when I opened it, the second it worked, but on the next map I was desync, like if I was doing a moonwalk at jumpmaze xD...
I'll open a ticket for that If it happen on the next tests (or if someone report the same iuse)
Projects
Cursed Maze: DONE, V2.0
Zombie Horde - ZM09 map update: [3/15/13]
Need help with English? Then you've come to the right place!

<this post is proof of "Decline">

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing; let's do this!

#27

Post by Torr Samaho » Thu Jan 02, 2014 6:43 pm

A fix is waiting to be tested for a couple of days now. Would be great if I can get some feedback on this soon, so that we can move to the next beta build.


User avatar
ibm5155
Addicted to Zandronum
Posts: 1640
Joined: Tue Jun 05, 2012 9:32 pm
Location: Somewhere, over the rainbow

RE: Zandronum 2.0 Testing; let's do this!

#29

Post by ibm5155 » Thu Jan 02, 2014 7:37 pm

it's not a problem but, alt+f4 doesn't close zandronum, instead it opens the menu. (sometimes I'm too lazy to manual close zan :s)
Projects
Cursed Maze: DONE, V2.0
Zombie Horde - ZM09 map update: [3/15/13]
Need help with English? Then you've come to the right place!

<this post is proof of "Decline">

Qent
Retired Staff / Community Team Member
Posts: 1424
Joined: Tue May 29, 2012 7:56 pm
Contact:

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#30

Post by Qent » Sat Jan 04, 2014 6:50 am

I am planning to do another public testing session the same time this week with Samsara and UDM3.

User avatar
IdeIdoom
Zandrone
Posts: 1112
Joined: Mon Jun 04, 2012 6:19 am
Location: Meldola, Italy
Contact:

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#31

Post by IdeIdoom » Sat Jan 04, 2014 9:09 am

ibm5155 wrote: it's not a problem but, alt+f4 doesn't close zandronum, instead it opens the menu. (sometimes I'm too lazy to manual close zan :s)
Ok, "no more Alt+f4 = you get BFG" trolling.
THE ROMANIAN POWERImage

Code: Select all

<+Dastan>	edd
<+Dastan>	boxxy skin when
<+Shift>	dastan you really want to fap at it this much and now you are going crazy and shredding your hair into a million tiny pieces for this boxxy skin to come out that way you can cum out
<+Dastan>	Shift, yes
--------------------------------------------------------------------
21:53:26  <@Estar>	well, if i'd be a girl, i would say ideidoom has ok looks

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#32

Post by Torr Samaho » Sat Jan 04, 2014 9:45 am

Qent wrote: I am planning to do another public testing session the same time this week with Samsara and UDM3.
Since some issues found during the last run are fixed by now, I'll try to release a new build before then.

User avatar
ibm5155
Addicted to Zandronum
Posts: 1640
Joined: Tue Jun 05, 2012 9:32 pm
Location: Somewhere, over the rainbow

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#33

Post by ibm5155 » Sat Jan 04, 2014 10:10 am

IdeIdoom wrote:
ibm5155 wrote: it's not a problem but, alt+f4 doesn't close zandronum, instead it opens the menu. (sometimes I'm too lazy to manual close zan :s)
Ok, "no more Alt+f4 = you get BFG" trolling.

ctrl+alt+delete + force close zandronum still works :cool:
Last edited by ibm5155 on Sat Jan 04, 2014 10:10 am, edited 1 time in total.
Projects
Cursed Maze: DONE, V2.0
Zombie Horde - ZM09 map update: [3/15/13]
Need help with English? Then you've come to the right place!

<this post is proof of "Decline">

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#34

Post by Torr Samaho » Sat Jan 04, 2014 12:31 pm

ibm5155 wrote: it's not a problem but, alt+f4 doesn't close zandronum, instead it opens the menu. (sometimes I'm too lazy to manual close zan :s)
Alt+F4 works just fine for me. If you think it's broken please make a tracker ticket.
ibm5155 wrote: Hey, does someone have some iuse with recorded demos? I tried one that I did to check the lag on jump maze testing, but, the first time I got a fatal error when I opened it, the second it worked, but on the next map I was desync, like if I was doing a moonwalk at jumpmaze xD...
I'll open a ticket for that If it happen on the next tests (or if someone report the same iuse)
I haven't seen a ticket on this yet. The only recent ticket with demo problems is about a center view problem that was already present in 1.2. I know you replied in this ticket, but since your 2.0 problem is unrelated to the 1.2 problem the ticket is about, please create a new ticket for the 2.0 demo issues.

Qent
Retired Staff / Community Team Member
Posts: 1424
Joined: Tue May 29, 2012 7:56 pm
Contact:

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#35

Post by Qent » Sun Jan 05, 2014 4:32 pm

Okay, surprise: Zandronum 2.0 cannot run Samsara. We may have to use a plain UDM3 server for now.

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#36

Post by Torr Samaho » Sun Jan 05, 2014 4:33 pm

Qent wrote: Okay, surprise: Zandronum 2.0 cannot run Samsara.
What's the problem?

EDIT: I see. Its SBARINFO code needs to be adjusted the ZDoom changes.
Last edited by Torr Samaho on Sun Jan 05, 2014 5:06 pm, edited 1 time in total.

Qent
Retired Staff / Community Team Member
Posts: 1424
Joined: Tue May 29, 2012 7:56 pm
Contact:

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#37

Post by Qent » Sun Jan 05, 2014 5:10 pm

We hit another speed bump: the Linux archive is still using the same zandronum.pk3 as beta 131223. We will use the zandronum.pk3 from the Windows archive, since most testers will probably be on Windows.

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#38

Post by Torr Samaho » Sun Jan 05, 2014 5:46 pm

Thanks for the info! I updated the Linux x86 archive to fix this. Unfortunately, our CMake files don't automatically update zandronum.pk3 if changes are made to the wadsrc directory. That's why the old version ended up in there.

Qent
Retired Staff / Community Team Member
Posts: 1424
Joined: Tue May 29, 2012 7:56 pm
Contact:

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#39

Post by Qent » Sun Jan 05, 2014 6:39 pm

Aside from one minor bug, the testing went well. Thanks again to everyone.

We will give Samsara another try after investigating what went wrong with SBARINFO.

User avatar
Torr Samaho
Lead Developer
Posts: 1532
Joined: Fri May 25, 2012 6:03 pm
Location: Germany

RE: Zandronum 2.0 Testing: Sundays 12 noon EST

#40

Post by Torr Samaho » Sun Jan 05, 2014 9:16 pm

Torr Samaho wrote: Its SBARINFO code needs to be adjusted the ZDoom changes.
Meanwhile I heard from Blzut3 that this is a ZDoom bug he just fixed. I'll backport his fix, so no change to Samsara (or any other mod) should be necessary to be compatible with 2.0.

Post Reply