help on raspberry pi 4+

General help and assistance forum.
Post Reply
User avatar
oddbenk
New User
Posts: 18
Joined: Sat Dec 10, 2016 7:36 pm

help on raspberry pi 4+

#1

Post by oddbenk » Tue Oct 08, 2019 9:05 pm

Hi!

I'm trying to run zandronum on my py4+ and I have two errors what I don't know how to solve.
I'm following this steps.
git clone https://github.com/doomtech/zandronum zandronum
cd zandronum
mkdir build
cd build
cmake ..
make
sudo make install
when I try to do step 7 I have two errors in my cmakeerror.log and in my cmakeoutput.log.

Hope that someone can help me out! Thanks!

cmakeerror.log.: https://pastebin.com/heRrfbWY
cmakeoutput.log.: https://pastebin.com/wADmaztD

User avatar
Sean
IRC Operator
Posts: 902
Joined: Thu Jan 16, 2014 9:09 pm
Location: England
Clan Tag: [TSPG]
Contact:

Re: help on raspberry pi 4+

#2

Post by Sean » Thu Oct 10, 2019 8:25 am

You should be using the official hg repo, not an outdated git mirror:

Code: Select all

hg clone https://bitbucket.org/Torr_Samaho/zandronum-stable zandronum
You'll also probably want to compile 3.0:

Code: Select all

cd zandronum
hg up ZA_3.0
<capodecima> i dont say any more word without my loyer jenova

User avatar
oddbenk
New User
Posts: 18
Joined: Sat Dec 10, 2016 7:36 pm

Re: help on raspberry pi 4+

#3

Post by oddbenk » Fri Oct 11, 2019 4:30 pm

thanks mate! sorry for my late reply but i was flooded at work. will check it out asap. again. thank you!

User avatar
oddbenk
New User
Posts: 18
Joined: Sat Dec 10, 2016 7:36 pm

Re: help on raspberry pi 4+

#4

Post by oddbenk » Thu Oct 17, 2019 9:13 pm

now as a complete newbie on linux. may I ask how to make it work with Doomseeker? I mean when I try to join a server Doomseeker asks me to locate the zandronum executable. all what you have wrote works fine but where can I find the executable to play online? Oo

Post Reply