Mac OS Zandronum crashes when launched via finder

General help and assistance forum.
Post Reply
User avatar
New User
Posts: 3
Joined: Thu Dec 04, 2014 11:09 pm
Clan Tag: ][=][ ][}}

Mac OS Zandronum crashes when launched via finder


Post by JavaLangMath » Wed Dec 13, 2017 12:12 am

I'm having a very strange issue with the Mac OS version of Zandronum. If I launch the from finder, the program allows me to select an IWAD but then silently crashes after I make a selection. I tried to troubleshoot the issue by manually running the zandronum binary via the terminal. I hoped that the terminal would output some exception or error that would normally be hidden in a GUI context. Much to my surprise, however, the zandronum binary worked just fine when executed from the terminal. I then attempted running Zandronum via joining a server through Doomseeker and this too worked just fine.

It seems as though the Mac client doesn't like to run under its own context for some reason.

According to my terminal output, the version I'm using is "Zandronum 3.0 - 170901-1140 - SDL version."

Are there any other Mac users that can reproduce this odd issue?

Post Reply