How to add bots from .cfg file

General discussion of the port and Doom-related chat.
User avatar
doomista
Topic author
Forum Regular
Offline
Posts: 137
Joined: 2 years ago

How to add bots from .cfg file

Post#1 by doomista » 2 months ago

Hi,

I have a server that autorestarts every day with randomized pwads and their respective configurations. Everything works fine except for the addbot command. It just won't do anything. Addmap command that requires sv_maprotation to be set (which is set) works just fine. Is there any undocumented variable I have to set prior to calling addbot or is something fundamentally wrong? Btw, I am using zandro 2.1.2.

Thanks for help in advance

User avatar
Kaminsky
Forum Regular
Offline
Posts: 140
Joined: 4 years ago

Re: How to add bots from .cfg file

Post#2 by Kaminsky » 2 months ago

Check to see if sv_disallowbots is false on your server. If it's set to true, bots cannot be added to the game because it won't generate the path nodes that bots need.

User avatar
doomista
Topic author
Forum Regular
Offline
Posts: 137
Joined: 2 years ago

Re: How to add bots from .cfg file

Post#3 by doomista » 2 months ago

It is false. Adding bots from remote console works.

User avatar
doomista
Topic author
Forum Regular
Offline
Posts: 137
Joined: 2 years ago

Re: How to add bots from .cfg file

Post#4 by doomista » 2 months ago

It does not work even in the newest build of Zandronum3, although I can add bots by passing +addbot [Name] parameter when starting zandronum


Return to “Zandronum Talk”



Who is online

Users browsing this forum: No registered users and 1 guest