Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003048Zandronum[All Projects] Suggestionpublic2017-04-07 23:262017-07-20 11:39
ReporterMaxRideWizardLord 
Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target VersionFixed in Version 
Summary0003048: Please, let us have multiplayer button back.
DescriptionThe multiplayer button is literally the most in-demand button in main menu that you have whenever you click ESC button once you connected to server, after maybe exit button. However, in new version of Zandronum 3.0, it's completely gone. That is absolutely inappropriate! I know that in some versions it's still lurking in general options (which is very uncomfortable to use anyway), but in other versions it's gone even from there. Without multiplayer button, you can't votemap a map you like; you can't votekick the AFK guy who prevents people from join survival game; and you can't adjust the most useful options that were in the multiplayer menu.
Steps To ReproduceOpen the main menu; it was fine the way it was.
Additional InformationMaybe have a client command which switches multiplayer button from main menu to options and vice versa for these who are nitpicky to the new design?
Attached Files? file icon multimenu.pk3 [^] (643 bytes) 2017-04-08 17:43

- Relationships

-  Notes
User avatar (0017088)
StrikerMan780 (reporter)
2017-04-07 23:46

It's not gone from any version. It's in Options. If it's missing, blame the author of any PWADs that end up changing anything other than the main menu.

(Speaking of which, if only MENUDEF had keywords to add entries to menus at the top or bottom of an existing menu instead of overwriting.)
User avatar (0017099)
Torr Samaho (administrator)
2017-04-08 13:09

Stiker is completely right. The multiplayer button is not gone, but simply moved to 'Options'.

Is there any mod that redefines 'Options' removing the button?
User avatar (0017109)
JC Tenton (reporter)
2017-04-08 15:44

There seems to be a little misunderstanding. Our complaint isn't about multiplayer button not being present at all. We just miss having it in the main menu.
User avatar (0017112)
Torr Samaho (administrator)
2017-04-08 17:44

We intentionally dropped the entry from the main menu to increase compatibility with ZDoom mods. If you want it back and don't worry about visual problems with some mods, try putting the file multimenu.pk3 I just attached to this ticket to your skins directory.
User avatar (0017113)
MaxRideWizardLord (reporter)
2017-04-08 20:06
edited on: 2017-04-09 03:28

I have never seen a mod which had a problem with a mere Multiplayer menu button being shown in the main menu. Although the only reason I suspect this change was even applied in the final version of Zandronum is that a mere visual look doesn't look so "pretty", which is completely and utterly irrelevant as the option is incredible useful and is in need to be at the most easiest and fastest access as possible. But for those who care so much about cosmetics, I suggested that maybe have a client command which switches Multiplayer button from main menu to options and vice versa for these who are nitpicky to the new design of main menu that any mod provides.

Just tested the file but it seem on some servers I have two Multiplayer buttons, both in the main menu and in the options. Also, some mods as well provided their own visual look of the Multiplayer button in the main menu and this file probably will either cause bugs or merely replace the old visual look with new one, which is not good. I suspect the file will cause bugs if the mod already provide the new visual look of the Multiplayer button in main menu, and I'm afraid the file will be messing up with the newer versions of Zandronum as they release.

And yes, there are lots of mods that cause the Multiplayer button to disappear completely from the main menu, even from the options, so there is no need to make a huge list of these. Even if the bug that cause the Multiplayer button to disappear from the options is fixed on the Zandronum side, it still would be incredibly uncomfortable to use, that's why we suggest to bring it back to the main menu, with perhaps the ability from a client side to switch it to the options if they care so much about the visual look of the main menu.

If I'm wrong and the Multiplayer button in the main menu truly caused incompatibility with some ZDoom mods that I'm not aware of, then I'd suggest to leave it as it is now, but please, let us have the option to enable the Multiplayer button to show in the main menu as long as it doesn't mess up with anything. Thanks for understanding.

User avatar (0017114)
Torr Samaho (administrator)
2017-04-09 08:51

We have to work with what ZDoom's new menu code allows for. A mod can replace any menu and no matter what custom additions we add to the default menus, they'll be gone when the mod replaces the menu. To be as consistent with ZDoom as possible, we decided to move the entry. The only thing we could do is to move the entry from the options menu to the main menu. It doesn't matter though if we do this inside zandronum.pk3 or if you do this in a file in your skins directory. Both methods should lead to exactly the same effect, none is more compatible with mods than the other. If you have an example where both lead to different results, please post it and I'll have a look.

In multimenu.pk3, I did not remove the entry from the options menu, but the file can be easily extended to do so.

What we could think about is a bind that allows to open the multiplayer menu directly. This would give even quicker access than the entry in the main menu and would be accessible even if the mod removes the multiplayer entry by replacing the menus.
User avatar (0017117)
Torr Samaho (administrator)
2017-04-09 19:18

FYI, you can open the multiplayer menu with "openmenu za_multiplayeroptions". Bind that to a key of your choice and you have an even quicker way to access that menu than via the main menu.
User avatar (0017292)
Torr Samaho (administrator)
2017-04-23 19:57

Since there was no further feedback, I assume that the existing options are sufficient. Thus, I'll close this ticket. If there are further questions, feel free to reopen the ticket.
User avatar (0018041)
MaxRideWizardLord (reporter)
2017-07-15 18:44

"The only thing we could do is to move the entry from the options menu to the main menu." - isn't this is what we been asking? As in, have the return of multiplayer menu from options menu to the main menu.

“Both methods should lead to exactly the same effect, none is more compatible with mods than the other. If you have an example where both lead to different results, please post it and I'll have a look” - can you please elaborate what you meant about this part?? I’m genuinely confused.

The ability to open multiplayer menu with a keybind while already in game is incredible uncomfortable and unnecessary, not to mention you would want to customize multiplayer before entering the game, and considering that zandronum is already very a lot of button-requiring program, I literally left no unbounded keys already…

Also, as I recently found out out, the multimenu.pk3 doesn't work for non-doom games like heretic or hexen.
User avatar (0018042)
Necronyam (reporter)
2017-07-15 18:59

I do agree, many new players are confused about the lack of multiplayer button and for that reason prefers to use old version of zandronum, for that reason I do believe it’s necessary to bring it back to the main menu.

Having the option that would allow us to bind that menu to certain button sound nice, but I’ve already spend every single button on my keyboard to bind special cvars and “cheat” commands in order to test my mods and their compatibility. I do really enjoy connect to server using multiplayer button as well. So I personally wish the multiplayer menu entry is back to main menu.

But I have extra question, what if the mod have multiplayer button entry with specific visual design and current zandronum does not, will it still appear in main menu regardless?
User avatar (0018044)
Edward-san (developer)
2017-07-15 21:02

I'd like to mention that GZDoom recently blocked the replacement of the options menu, so whatever a mod is planning for the multiplayer button may not work anymore in a future version of Zandronum.
User avatar (0018046)
Ru5tK1ng (updater)
2017-07-15 23:50

What's so confusing about highlighting 'Options' and pressing enter twice? Quite literally the same menu as clicking the old Multiplayer option.
User avatar (0018048)
Ivan (reporter)
2017-07-16 14:03

This is a pointless thing that has caused more harm than good. Just get used to the change, it's literally a few more clicks. I can't believe people are even using that menu in the first place...
User avatar (0018061)
Jenkins95 (reporter)
2017-07-17 22:42

Well, considering this is the most used button in the whole Zandronum... Yes, it should be in the main menu, i guess.
User avatar (0018063)
Ivan (reporter)
2017-07-18 11:15

Why or how is this the most used menu?
User avatar (0018065)
Combinebobnt (reporter)
2017-07-18 21:43

Compatibility with zdoom menus > your inability to accept a painless change. Idk who would even bother with the ingame browser rather than the external ones and I find just typing 'multiplayer' in console way faster than dealing with all the dumb menu sliders. Hell everything in the menu is faster in the console probably.

Don't try the 'people will use an earlier version'
1. No
2. People tried that excuse thinking skulltag 98d is superior to zandronum because we 'removed' some dumb black imps that have 2x hp or whatever idiot logic they have.
3. Someone named 'DumbMoron' supports this ticket. Enough said.
User avatar (0018066)
Ru5tK1ng (updater)
2017-07-19 01:05

Quote
I do agree, many new players are confused about the lack of multiplayer button and for that reason prefers to use old version of zandronum, for that reason I do believe it’s necessary to bring it back to the main menu.

If a player was TRULY new, they wouldn't even have knowledge of a 'Multiplayer Option'. It doesn't exist in ZDoom/GZDoom, ZDaemon or even Odamex. Anyway, the Multiplayer Option is the first thing highlighted when you enter options from the main menu.


Quote
Well, considering this is the most used button in the whole Zandronum...

Do you have any proof for that or are you just making baseless statements? I can do that too by saying people use the console to input commands more than they use the menu.

Regardless if either statement is correct, the point still stands that the Multiplayer menu is still very easily accessible in 3.0. All you have to do is select the options menu and the FIRST thing selected is Multiplayer Options.

I don't know why people are acting like a tutorial is needed on how to find Multiplayer options. The 'unacceptable' and 'dire' effects of removing the option are overstated. For starters no one bothered to even post in this ticket when Torr was seeking feedback except for 2 people. Yet, it is supposed to be believed that this is an issue that's somehow threatening to destroy Zandronum...
User avatar (0018067)
Fused (reporter)
2017-07-20 11:36
edited on: 2017-07-20 11:39

I totally forgot that menu existed until I found this ticket. It's definitely not the most used menu at all.
I'd say if you really want it, the best option here is to have the engine readd it at the top of the menu list when mods supply a custom menu, and the mod didn't add a multiplayer button.
I see no reason to readd it to the main menu when it's only an extra click away, and zdoom basically locked it in a future version anyways. Zandronum/Zdoom is supposed to give freedom to modders, and if they hapen to remove a menu, you shouln't really do anything about that. I removed some myself since I don't need half of them in my mod.


Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: Korshun JC Tenton whitewolf9313 DumbMoron MaxRideWizardLord DarkSnack Jenkins95 N30N Yesnomaybe djskaarj Necronyam Monsterovich KirovNoir ArathHunter Brightness Filystea
Opponents: Ivan Leonard Argentum Combinebobnt Kaminsky Ru5tK1ng

- Issue History
Date Modified Username Field Change
2017-04-07 23:26 MaxRideWizardLord New Issue
2017-04-07 23:46 StrikerMan780 Note Added: 0017088
2017-04-08 13:09 Torr Samaho Note Added: 0017099
2017-04-08 13:10 Torr Samaho Status new => feedback
2017-04-08 15:44 JC Tenton Note Added: 0017109
2017-04-08 17:43 Torr Samaho File Added: multimenu.pk3
2017-04-08 17:44 Torr Samaho Note Added: 0017112
2017-04-08 20:06 MaxRideWizardLord Note Added: 0017113
2017-04-08 20:06 MaxRideWizardLord Status feedback => new
2017-04-09 03:28 MaxRideWizardLord Note Edited: 0017113 View Revisions
2017-04-09 08:51 Torr Samaho Note Added: 0017114
2017-04-09 09:12 Torr Samaho Status new => feedback
2017-04-09 19:18 Torr Samaho Note Added: 0017117
2017-04-23 19:57 Torr Samaho Note Added: 0017292
2017-04-23 19:57 Torr Samaho Status feedback => closed
2017-04-23 19:57 Torr Samaho Resolution open => no change required
2017-07-15 18:44 MaxRideWizardLord Note Added: 0018041
2017-07-15 18:44 MaxRideWizardLord Status closed => feedback
2017-07-15 18:44 MaxRideWizardLord Resolution no change required => reopened
2017-07-15 18:59 Necronyam Note Added: 0018042
2017-07-15 21:02 Edward-san Note Added: 0018044
2017-07-15 23:50 Ru5tK1ng Note Added: 0018046
2017-07-16 14:03 Ivan Note Added: 0018048
2017-07-17 22:42 Jenkins95 Note Added: 0018061
2017-07-18 11:15 Ivan Note Added: 0018063
2017-07-18 21:43 Combinebobnt Note Added: 0018065
2017-07-19 01:05 Ru5tK1ng Note Added: 0018066
2017-07-20 11:36 Fused Note Added: 0018067
2017-07-20 11:37 Fused Note Edited: 0018067 View Revisions
2017-07-20 11:38 Fused Note Edited: 0018067 View Revisions
2017-07-20 11:39 Fused Note Edited: 0018067 View Revisions






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker