Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002803Zandronum[All Projects] Bugpublic2016-08-13 16:102017-03-05 19:31
ReporterRemmirath 
Assigned ToTorr Samaho 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionreopened 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version2.1 
Target Version3.1Fixed in Version 
Summary0002803: Actor Hits Floor CTD
DescriptionI've ran into this bug while making a map.

I've setup 2 teleporters with Actor Hits Floor trigger. However if you drop on the teleporter from a height greater than your jump height, Zandronum will crash to desktop.
Steps To ReproduceI've made a test map to quickly reproduce this.

1) Get high jump rune
2) Jump over one of the teleporters and land on it, or alternatively, drop from the 3D floor placed in the map
3) The landing should make Zandronum crash to desktop

Attached Files? file icon actor_hits_floor_bug.wad [^] (8,168 bytes) 2016-08-13 16:10

- Relationships
duplicate of 0001985closed actor hits floor thing teleport crash 

-  Notes
User avatar (0015444)
Dusk (developer)
2016-08-13 16:47

Your map basically has the two teleporters linked together. The teleporter first teleports the player to the other teleporter, which then teleports the player back to the first one, which teleports the player back to the other one, etc.

This was already ruled out as a can't fix by ZDoom.
User avatar (0015445)
Dusk (developer)
2016-08-13 18:46

http://forum.zdoom.org/viewtopic.php?f=7&t=53168 [^]

ZDoom has now added a compatibility flag, compat_teleport, for this.
User avatar (0016941)
Torr Samaho (administrator)
2017-03-05 19:31

For the record, both 2.1.2 and 3.0 crash with the example wad.

Issue Community Support
Only registered users can voice their support. Click here to register, or here to log in.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-08-13 16:10 Remmirath New Issue
2016-08-13 16:10 Remmirath File Added: actor_hits_floor_bug.wad
2016-08-13 16:21 WaTaKiD Relationship added duplicate of 0001985
2016-08-13 16:21 WaTaKiD Status new => closed
2016-08-13 16:21 WaTaKiD Resolution open => duplicate
2016-08-13 16:47 Dusk Note Added: 0015444
2016-08-13 18:46 Dusk Assigned To => Torr Samaho
2016-08-13 18:46 Dusk Note Added: 0015445
2016-08-13 18:46 Dusk Status closed => feedback
2016-08-13 18:46 Dusk Resolution duplicate => reopened
2016-12-24 22:43 Dusk Target Version => 3.0
2017-02-06 19:47 Dusk Status feedback => assigned
2017-02-06 19:47 Dusk Target Version 3.0 => 3.1
2017-03-05 19:30 Torr Samaho Product Version 3.0-beta => 2.1
2017-03-05 19:31 Torr Samaho Note Added: 0016941






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker