Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002617Zandronum[All Projects] Bugpublic2016-02-04 02:262017-04-19 19:35
ReporterLance 
Assigned ToTorr Samaho 
PriorityhighSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version3.0-beta 
Target Version3.0Fixed in Version3.0 
Summary0002617: ACS loop problem in 3.0
DescriptionI'm not exactly sure what the problem is, but one of my mods takes place from a third-person perspective. Recently I've tried running the mod on Zandronum 3.0 to debug it for the newer build. I've not found any problems, except for one that heavily conflicts with the core of this mod. The mod uses an entirely client-sided script to give the player his own camera that follows him behind around the map, much like Zdoom's chasecam. This is the only way to enforce a third-person camera in Zandronum. I thought it worked fine, but in 3.0 the camera updates very slow and is very choppy. Where as in Zandronum 2.1 the camera is smooth and updating consistantly. The script is a while loop that updates every tic. This has not been tested online.
Attached Files? file icon camera.pk3 [^] (1,022 bytes) 2016-02-04 02:26

- Relationships
related to 0003028resolvedTorr Samaho Backport Warp ACS function 

-  Notes
User avatar (0014311)
Lance (reporter)
2016-02-04 02:33

This bug can be reproduced on GZDoom 1.8.6. My apologies, I should've posted that in the description.
User avatar (0014313)
Edward-san (developer)
2016-02-04 10:37
edited on: 2016-02-04 10:38

Can you reproduce this with latest gzdoom build from here? You can test either the '1.8.10' series or the '2.1.pre' ones.

User avatar (0014314)
Lance (reporter)
2016-02-04 20:24

It has been reproduced in both.
User avatar (0014315)
Edward-san (developer)
2016-02-04 20:32
edited on: 2016-02-04 20:41

Reported in zdoom bug thread (cl_capfps 0 is mandatory):http://forum.zdoom.org/viewtopic.php?f=2&t=50686 [^]

User avatar (0014316)
Edward-san (developer)
2016-02-04 23:13
edited on: 2016-02-04 23:14

[Not a bug].

It seems you should try using Warp instead in order to achieve the same smoothness as before.

User avatar (0014317)
Lance (reporter)
2016-02-05 01:10

Just tested this on Zandronum 3.0, it seems the Warp function is not implemented. This may cause compatibility problems for any mod using a similar solution for the camera (arkdoom for example) where the camera will have extreme choppiness due to the camera only updating in a 35 fps window. SetActorPosition no longer has interpolation while Warp does. In the current build of GZDoom Zandronum is based from Warp is not availible, leaving no resolution to this problem.
User avatar (0017036)
Cutman (reporter)
2017-03-20 19:19

Ticket 0003028 is also a request to backport ACS Warp. Not sure how useful it is but we do have the DECORATE version in 3.0 already.
User avatar (0017037)
Torr Samaho (administrator)
2017-03-20 19:32

So you can work around this in MM8BDM with DECORATE?
User avatar (0017038)
Cutman (reporter)
2017-03-20 19:35
edited on: 2017-03-20 19:42

I believe the mod(s) they're talking about are unrelated to 8bdm and we have (8bdm ) no need for the ACS Warp function (yet?)

User avatar (0017039)
Torr Samaho (administrator)
2017-03-20 19:47

I see, thanks for clarifying.
User avatar (0017081)
Torr Samaho (administrator)
2017-04-02 20:46
edited on: 2017-04-08 13:48

The implementation of the Warp ACS function unfortunately is spread over many commits in ZDoom, so backporting it fully is not really feasible. Would the version from GLOOME (with the function number from ZDoom) be sufficient, i.e.https://bitbucket.org/Torr_Samaho/zandronum-zdoom-sync/commits/afabdc83c31e2eee44bb354cd1ba56f1596fbd42 [^] ?

User avatar (0017104)
Torr Samaho (administrator)
2017-04-08 13:49

0003028:0017103
User avatar (0017208)
Ru5tK1ng (updater)
2017-04-19 01:14

Tested this with the latest build and to my eyes it still looks choppy when compared to 2.1.2.
User avatar (0017215)
Torr Samaho (administrator)
2017-04-19 06:17

The behavior of the example wad will not change. ZDoom removed the interpolation from SetActorPosition, that's why camera.pk3 is choppy. I just supplied GLOOME's ACS Warp variant to give mod authors a ZDoom compatible way to fix the choppy movement by adjusting their mod to ZDoom's change.
User avatar (0017225)
Ru5tK1ng (updater)
2017-04-19 19:35

Ah I see. Well based on Sean's findings in 3028 regarding warp, I'll mark this as fixed.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: AOSP
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2016-02-04 02:26 Lance New Issue
2016-02-04 02:26 Lance File Added: camera.pk3
2016-02-04 02:33 Lance Note Added: 0014311
2016-02-04 10:37 Edward-san Note Added: 0014313
2016-02-04 10:37 Edward-san Status new => feedback
2016-02-04 10:38 Edward-san Note Edited: 0014313 View Revisions
2016-02-04 20:24 Lance Note Added: 0014314
2016-02-04 20:24 Lance Status feedback => new
2016-02-04 20:32 Edward-san Note Added: 0014315
2016-02-04 20:32 Edward-san Status new => acknowledged
2016-02-04 20:32 Edward-san Resolution open => waiting for zdoom
2016-02-04 20:41 Edward-san Note Edited: 0014315 View Revisions
2016-02-04 20:41 Edward-san Note Edited: 0014315 View Revisions
2016-02-04 23:13 Edward-san Note Added: 0014316
2016-02-04 23:14 Edward-san Note Edited: 0014316 View Revisions
2016-02-04 23:15 Edward-san Status acknowledged => feedback
2016-02-04 23:15 Edward-san Resolution waiting for zdoom => open
2016-02-04 23:22 Dusk Status feedback => closed
2016-02-04 23:22 Dusk Resolution open => no change required
2016-02-05 01:10 Lance Note Added: 0014317
2016-02-05 01:10 Lance Status closed => feedback
2016-02-05 01:10 Lance Resolution no change required => reopened
2016-12-03 11:49 Dusk Priority normal => high
2016-12-03 11:49 Dusk Target Version => 3.0-beta
2017-03-19 14:06 Torr Samaho Target Version 3.0-beta => 3.0
2017-03-20 19:19 Cutman Note Added: 0017036
2017-03-20 19:25 Torr Samaho Relationship added related to 0003028
2017-03-20 19:32 Torr Samaho Note Added: 0017037
2017-03-20 19:35 Cutman Note Added: 0017038
2017-03-20 19:42 Cutman Note Edited: 0017038 View Revisions
2017-03-20 19:47 Torr Samaho Note Added: 0017039
2017-04-02 20:46 Torr Samaho Note Added: 0017081
2017-04-08 13:48 Torr Samaho Note Edited: 0017081 View Revisions
2017-04-08 13:49 Torr Samaho Note Added: 0017104
2017-04-08 13:49 Torr Samaho Note Revision Dropped: 17081: 0010291
2017-04-08 13:50 Torr Samaho Assigned To => Torr Samaho
2017-04-08 13:50 Torr Samaho Status feedback => needs testing
2017-04-19 01:14 Ru5tK1ng Note Added: 0017208
2017-04-19 01:14 Ru5tK1ng Status needs testing => feedback
2017-04-19 06:17 Torr Samaho Note Added: 0017215
2017-04-19 19:35 Ru5tK1ng Note Added: 0017225
2017-04-19 19:35 Ru5tK1ng Status feedback => resolved
2017-04-19 19:35 Ru5tK1ng Resolution reopened => fixed
2017-04-19 19:35 Ru5tK1ng Fixed in Version => 3.0






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker