Zandronum Chat @ irc.zandronum.com
#zandronum
Get the latest version: 2.1.2
Source Code

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002442Zandronum[All Projects] Bugpublic2015-09-06 13:222016-12-28 18:46
ReporterZalewa 
Assigned ToZalewa 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformMicrosoftOSWindowsOS VersionXP/Vista/7
Product Version2.1 
Target Version3.0Fixed in Version3.0 
Summary0002442: Doomguy's face background color doesn't change after color CCMD in online game with OpenGL renderer
DescriptionDoomguy's face background color doesn't change after color CCMD in online game. It also doesn't change when changing colors from player setup menu.
Steps To Reproduce1. Run a cooperative server (or deathmatch, doesn't matter).
2. Join this server.
3. Shrink HUD so that the original Doom HUD bar with doomguy's face is visible.
4. Start changing colors with "COLOR" CCMD.
5. Observe background color on the HUD not changing.
Additional InformationAlso happens in Zandronum 3.0.
Attached Files

- Relationships

-  Notes
User avatar (0015911)
unknownna (updater)
2016-10-11 23:17

This caused by having cl_overrideplayercolors enabled. If it's enabled, you have to change the color through cl_allycolor. All of the override options seem to have an effect in coop, whether intentional or not.

If you feel that this shouldn't be the case, you could make a new ticket for further discussion.
User avatar (0015921)
Zalewa (developer)
2016-10-12 15:19

Nothing of what you said applies to what was reported nor what is actually happening. See the video:https://youtu.be/bcp5bM_al8A [^] . Pay attention to the HUD face. Let developers decide when the tickets are to be closed.
User avatar (0015930)
Edward-san (developer)
2016-10-12 19:30
edited on: 2016-10-12 19:39

Can't reproduce with either 2.1.2 or my latest 3.0 build. No clue about the issue here.

[edit] Nvm, it happens only when the GL renderer is used.

User avatar (0015931)
WaTaKiD (updater)
2016-10-12 19:40
edited on: 2016-10-12 19:41

i can reproduce this in 2.1.2, 3.0-r160814-2010, and 3.0-r161011-1923

edit: oh ninja'd, yea it does only happen in ogl

User avatar (0015941)
unknownna (updater)
2016-10-13 00:00

Good, now we can rule out cl_overrideplayercolors at least. This seems to have been broken since forever. It's also broken in Skulltag 98d.
User avatar (0016495)
Zalewa (developer)
2016-12-15 22:25

Pull request:
https://bitbucket.org/Torr_Samaho/zandronum/pull-requests/177/mugshot-multiplayer-background-color-didnt/diff [^]
User avatar (0016517)
Torr Samaho (administrator)
2016-12-17 15:42

Thanks! I added your patch.
User avatar (0016560)
Ru5tK1ng (updater)
2016-12-28 18:46

Tested online with the fix and it seems to work perfectly.

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
2015-09-06 13:22 Zalewa New Issue
2016-10-11 23:17 unknownna Note Added: 0015911
2016-10-11 23:17 unknownna Status new => closed
2016-10-11 23:17 unknownna Resolution open => no change required
2016-10-12 15:19 Zalewa Note Added: 0015921
2016-10-12 15:19 Zalewa Status closed => new
2016-10-12 19:30 Edward-san Note Added: 0015930
2016-10-12 19:39 Edward-san Note Edited: 0015930 View Revisions
2016-10-12 19:40 WaTaKiD Note Added: 0015931
2016-10-12 19:41 WaTaKiD Note Edited: 0015931 View Revisions
2016-10-13 00:00 unknownna Note Added: 0015941
2016-10-13 00:00 unknownna Status new => confirmed
2016-10-13 00:00 unknownna Resolution no change required => open
2016-10-13 00:00 unknownna Summary Doomguy's face background color doesn't change after color CCMD in online game. => Doomguy's face background color doesn't change after color CCMD in online game with OpenGL renderer
2016-12-15 22:20 Zalewa Assigned To => Zalewa
2016-12-15 22:20 Zalewa Status confirmed => assigned
2016-12-15 22:25 Zalewa Note Added: 0016495
2016-12-15 22:25 Zalewa Status assigned => needs review
2016-12-17 15:42 Torr Samaho Note Added: 0016517
2016-12-17 15:42 Torr Samaho Status needs review => needs testing
2016-12-17 15:42 Torr Samaho Target Version => 3.0
2016-12-28 18:46 Ru5tK1ng Note Added: 0016560
2016-12-28 18:46 Ru5tK1ng Status needs testing => resolved
2016-12-28 18:46 Ru5tK1ng Resolution open => fixed
2016-12-28 18:46 Ru5tK1ng Fixed in Version => 3.0






Questions or other issues? Contact Us.

Links


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker